How to embed in a Wordpress blog

10 years ago

How do you embed the Tagul into a Wordpress blog? I copied the code and pasted it into my wordpress blog but it does not appear.

10 years ago

1) Do you use the percentage metrics? If you do try to use the fixed one and watch your width and height attributes carefully.
2) For wordpress you could use WP-SWFObject plugin (http://blog.unijimpe.net/wp-swfobject/) and use the following code to embed:
[SWF]http://cdn.tagul.com/cloud.swf, 600, 500, id=<you cloud id>[/SWF]

Change <you cloud id> to the real id of your cloud that can be found in the embedding code, e.g. <param name="flashvars" value="id=1@14"> your id 1@14.

10 years ago

hello, actually i just tried to put it on my livejournal by copying the embedding code over, but it doesn't work ... does this solution work the same way? or is the WP-SWObject plugin thing different for livejournal? thanks!

10 years ago

WP-SWObject plugin won't work for livejournal, you should use the embedding code on the "Finalize" tab. You can try to use the fixed measurement (not percentage).

Here is an example of successfull embedding in livejournal http://pdlloyd.livejournal.com/76909.html

9 years ago

Hi,

I´ve embedded the Tagul with a [swf]-code using the WP-SWObject since I was not able to just use the plain html embed code provided by the generator. And Im getting the embedded flash up, but it doesnt contain any tags, only the text "N/A".
Am I just not patient enough, or am I doing something wrong?

Here´s the code:
[SWF]http://cdn.tagul.com/cloud.swf, 600, 500, id=<3411@2>[/SWF]
and the blog:
http://3260bjo250.iblogger.org/?p=3

9 years ago

All of a sudden it just work, odd :P

I only installed the WP Cumulus plugin (alternative tag cloud generator, running on the WP server), and the tagul just worked.

Weird!

9 years ago

Gullars,

the correct code while embedding with WP-SWFObject

[SWF]http://cdn.tagul.com/cloud.swf, 600, 500, id=3411@2[/SWF]

You should remove "<" and ">" from your code.

9 years ago

Gullars,

just visited your blog and realized that your cloud is not clickable. That is because SWF object plugin does not have allowScriptAccess="always" parameter.
To enable it you should change the wp-swfobject.php code

// Use SWFObject 2.0 code
$wpswf_params = "wmode: \\"".$wpswf_config[\'swf_wmode\']."\\", ";
$wpswf_params.= "menu: \\"".$wpswf_config[\'swf_menu\']."\\", ";
$wpswf_params.= "quality: \\"".$wpswf_config[\'swf_quality\']."\\", ";
$wpswf_params.= "bgcolor: \\"".$wpswf_config[\'swf_bgcolor\']."\\"";

to

// Use SWFObject 2.0 code
$wpswf_params = "wmode: \\"".$wpswf_config[\'swf_wmode\']."\\", ";
$wpswf_params.= "menu: \\"".$wpswf_config[\'swf_menu\']."\\", ";
$wpswf_params.= "quality: \\"".$wpswf_config[\'swf_quality\']."\\", ";
$wpswf_params.= "bgcolor: \\"".$wpswf_config[\'swf_bgcolor\']."\\"";
$wpswf_params.= ", allowScriptAccess: \\"always\\"";

The last line adds allowScriptAccess parameter.

Reply

Sign up or Login to post a reply.